Jump to content
Nytro

Modificari forum

Recommended Posts

Haideti, cei care va pricepeti la frontend, ceva solutii?

Si nu, nu vreau sa verific un cookie/localStorage, daca nu e setat fac un refresh si il setez. Vreau ceva mai profesional. :D

Share this post


Link to post
Share on other sites
5 minutes ago, Nytro said:

Haideti, cei care va pricepeti la frontend, ceva solutii?

Si nu, nu vreau sa verific un cookie/localStorage, daca nu e setat fac un refresh si il setez. Vreau ceva mai profesional. :D

Vezi să nu fie ceva problemă de caching. 

Share this post


Link to post
Share on other sites
3 minutes ago, Gecko said:

Nu pot reproduce eroarea. Deschideti consola si copiati erorile. CTRL SHIFT J

Nu-s erori de niciun fel. @Nytro,verifică treaba cu cachingul. Sunt aproape sigur că de la aia e.

  • Upvote 1

Share this post


Link to post
Share on other sites
5 hours ago, Silviu said:

Nu-s erori de niciun fel. @Nytro,verifică treaba cu cachingul. Sunt aproape sigur că de la aia e.

Nu chiar. Cred ca mai de graba tine de browser internals...

Am deschis WebApp-ul in mai multe browsere in ferestre incognito si singurul care face pe nebunul pare sa fie Google Chrome:

Daca va uitati atent, Google Chrome ramane blocat la un "Establishing secure connection..." desi in "Network" pane nu apare sa fie vre-o conexiune initializata si neterminata... Nu stiu ce asteapta.

Ce este "clar" este ca nu ruleaza niciodata app.js, adica aplicatia.

Si mai ciudat de atat, daca il opresti din incarcat (ramane in "Establishing secure connection..." mult si bine), si ii ceri sa reincarce pagina (permitand folosirea fisierelor din cache), va functiona corect.

 

L.E.: Daca pui un break-point pe linia 3 in app.js (unde este definita aplicatia) si ii dai "Resume script execution" dupa ce a fost atins, WebApp-ul functioneaza. Concluzia mea este ca problema apare din modul in care incarca angularjs (sau modul in care vede incarcate) anumite fisiere/module.

Thoughts @Gecko?

Edited by u0m3
Added more info
  • Upvote 4

Share this post


Link to post
Share on other sites

Da, ma gandeam ca e de la vreun update de IPBoard, dar pare sa fie ceva de caching.

Ce sa fac, sa pun local toate JS-urile/CSS-urile, iar JS-urile sa le pun la final? 

Share this post


Link to post
Share on other sites
1 hour ago, Nytro said:

Da, ma gandeam ca e de la vreun update de IPBoard, dar pare sa fie ceva de caching.

Ce sa fac, sa pun local toate JS-urile/CSS-urile, iar JS-urile sa le pun la final? 

Scoate caching-ul de pe jucăria făcută de @Gecko.

Share this post


Link to post
Share on other sites

Fixed. Ca fapt divers, cred ca mergea si daca le marcai defered

<script defer src="myscript.js"></script>

Sau daca faceai bootstrap separat.

Share this post


Link to post
Share on other sites
37 minutes ago, Massaro said:

La mine e la fel...

Hmm, interesant... Ce broser folosesti?

Share this post


Link to post
Share on other sites
1 hour ago, Nytro said:

Acum merge?

Am mutat JS-urile (puse local) in jos-ul paginii. 

La mine nu se mai reproduce, dar nu cred că asta era problema. 

Edited by Silviu

Share this post


Link to post
Share on other sites
1 hour ago, Massaro said:

La mine e la fel...

 

Baga un ctrl + f5 sau deschide in incognito, posibil sa fie ceva la tine in cache. Si la mine pe Chrome arata asa dar acum e ok.

Share this post


Link to post
Share on other sites
53 minutes ago, u0m3 said:

Hmm, interesant... Ce broser folosesti?

Chromium Version 64.0.3282.167 (Official Build)

 

18 minutes ago, QuoVadis said:

 

Baga un ctrl + f5 sau deschide in incognito, posibil sa fie ceva la tine in cache. Si la mine pe Chrome arata asa dar acum e ok.

La fel. 

Share this post


Link to post
Share on other sites
2 hours ago, aelius said:

Unde?

In mail, s**********ts@yahoo.com acesta nu e al meu niciodata in viata

 

Edited by .zife

Share this post


Link to post
Share on other sites

Salutari,

 

 Avem un moderator nou, @ThaiFight . Nu este un om cu foarte multe cunostinte tehnice dar este corect.

Daca vreti sa dati de baut, cafeaua la mine iar vinul la Nytro. :)

  • Upvote 8

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...